diff source/CMakeLists.txt @ 0:09fe40627f03 draft

commit JCT-VC HM source with cmake based build scripts HM-10.0-dev@3375 with some parts trimmed and some trivial folder reorgs https://hevc.hhi.fraunhofer.de/svn/svn_HEVCSoftware/
author Steve Borho <steve@borho.org>
date Wed, 06 Mar 2013 21:29:23 -0600
parents
children 99bb609ac6da
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/source/CMakeLists.txt	Wed Mar 06 21:29:23 2013 -0600
@@ -0,0 +1,18 @@
+project (xhevc)
+cmake_minimum_required (VERSION 2.6)
+
+# Enforce coding standards.  Full warnings and warnings as errors
+if(MSVC)
+    # would prefer /W4 but the HM source did not compile at /W4
+    add_definitions(/W3 /WX /D_CRT_SECURE_NO_WARNINGS)
+    include_directories(compat/msvc)
+endif(MSVC)
+if(CMAKE_COMPILER_IS_GNUCXX)
+    add_definitions(-Wall -Werror)
+endif(CMAKE_COMPILER_IS_GNUCXX)
+
+include_directories(Lib)
+
+add_subdirectory(Lib)
+add_subdirectory(App/TAppEncoder)
+add_subdirectory(App/TAppDecoder)